Error in installing certificate

I have followed steps to install the certificate and have received below message, but my website is still showing unsecured.

My domain is:

I ran this command: certbot --webroot -w /opt/bitnami/apps/wordpress/htdocs -d -d --test-cert -i apache

It produced this output:

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 1
The selected vhost would conflict with other HTTPS VirtualHosts within Apache. Please selec
t another vhost or add ServerNames to your configuration.
VirtualHost not able to be selected.


  • Unable to install the certificate
  • Congratulations! Your certificate and chain have been saved at:
    Your key file has been saved at:
    Your cert will expire on 2019-12-30. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the “certonly” option. To non-interactively renew all of
    your certificates, run “certbot renew”

My web server is (include version): apache

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Hi @arpita

if you use a Bitnami, Certbot isn't able to install the certificate. So -i apache can't work.

  • Use certonly instead
  • Check your Bitnami documentation how to convert a certificate from *.pem files to the format Bitnami uses.

There are different Bitnami versions and different solutions possible. And some Bitnami versions have scripts to do that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.