Certificate with cloud hosting

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: coinpos.org

I ran this command: sudo certbot --apache

It produced this output: Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 2
The selected vhost would conflict with other HTTPS VirtualHosts within Apache. Please select another vhost or add S
erverNames to your configuration.
Could not install certificate

  • The certificate was saved, but could not be installed (installer: apache). After fixing the error shown below, tr
    y installing it again by running:
    certbot install --cert-name coinpos.org
    VirtualHost not able to be selected.
    Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/let
    sencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): Apache

The operating system my web server runs on is (include version): Debian 10

My hosting provider, if applicable, is: Google Cloud

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

hello im trying to Setup SSL for WordPress on Google Cloud (Click-to-Deploy) but i get error. please help me to resolve this problem

This type of error is caused by overlapping HTTPS virtual hosts in the configuration in your webserver.

Ultimately you need to organize your domains so that they do not overlap.

A good place to get started is to post your current virtual host set up, which you can view by running:

sudo apachectl -t -D DUMP_VHOSTS

hello @_az
thank you for replying . After writing the command, I got this result

VirtualHost configuration:
*:80                   coinpos-site-vm.europe-west4-a.c.pro-zone-346321.internal (/etc/apache2/sites-enabled/000-de
*:443                  coinpos-site-vm.europe-west4-a.c.pro-zone-346321.internal (/etc/apache2/sites-enabled/wordpr
1 Like

Uh, hmmm.

If you try:

sudo a2dissite wordpress-https
sudo certbot install --cert-name coinpos.org

Does that help?


@_az Wow thanks thanks thanks. Finally, the problem was resolved and the certificate was accepted. I've been trying since yesterday to no avail, now my problem has been resolved. :grinning:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.