Docker ==> Network unreachable


#1

PROBLEM SOLVED : SEE SOLUTION HERE

Hi,

I have a docker container (from debian:stretch) on which I installed apache2 to run a website.

My container has ports 80->80/tcp and 443->443/tcp opened. After successfully installing the HTTPS, when I try to access my site in https it says to me: The connection failed (it’s working fine on http). However, I’m used to this kind of thing, so I’m pretty sure of myself by telling you that I didn’t make any mistakes in the configuration.

I’m out of ideas… Maybe you?

Hope you can help me :slight_smile:


#2

More information will be a GREAT help.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#3

Hello @Rip,

Thanks for your help.

I’ve solved the problem (I have to bind both tcp and udp) with those steps :

  1. $ docker stop container-name
  2. $ docker commit container-name new-image
  3. $ docker run -ti --name new-container-name -p 80:80 -p 443:443 -p 443:443/udp new-image

closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.