After installing the certificate why does my site say "Your connection is not secure"


#1

Please fill out the fields below so we can help you better.

My domain is:enstartup.com

I ran this command:installing the certificate

It produced this output:your connection is not private

My operating system is (include version): ubuntu 16.04

My web server is (include version): apache2

My hosting provider, if applicable, is:digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know):no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no


#2

I’m not able to connect to this domain on port 443 for HTTPS. Do you have a firewall or something else that might be blocking the connection? Is the Apache service up and running?


#3

I got:
This site can’t be reached
enstartup.com refused to connect.
FWIW, it was
https://enstartup.com

Dumb question- where/how did yourun the command? does digitalocean support LE in cPanel or whatever? Ask them.


#4

no i didnt have a firewall running on it. and apache service is up


#5

Have you tried accessing the server from an external vantage point?

I’m still unable to connect:

$ dig +short enstartup.com
159.203.227.62
$ openssl s_client -connect enstartup.com:443
connect: Connection refused
connect:errno=111

#6

I show port 80 open, but port 443 is closed (not filtered or dropped like a firewall). This might be a dumb question, but are you sure Apache configured to listen on port 443 (with the Listen directive)?


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.