Certificate installed, still secure connection failed

I am trying to install certificates for an Apache server, following this tutorial https://linuxize.com/post/secure-apache-with-let-s-encrypt-on-ubuntu-18-04/ I have successfully obtained the certificates using certbot. However my domain is still not secured. If I try to access https://anamitra.me/ it says secure connection failed. How can I resolve this issue?

My domain is: anamitra.me

My web server is (include version): Apache 2

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: Scaleway

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): NA

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.27.0

Hi @onnyyonn

read the output of your check, ~~30 minutes old - https://check-your-website.server-daten.de/?q=anamitra.me

Your port 443 is a http port -> Grade Q with the Apache default page. And you have created two certificates.

So disable your port 443, then

certbot --reinstall -d anamitra.me  -d www.anamitra.me -i apache

to create a working port 443.

Try with certbot install


This is needlessly complicated. Did you include the “SSLEngine On” line?

Thanks for your replies. That tutorial I was following was needlessly complicated indeed. I ran the following command and followed the instructions and that solved the issue.

certbot --reinstall -d anamitra.me  -d www.anamitra.me -i apache
2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.