DNS Provider Not Allowing TXT Records to Be Submitted Correctly - LetsEncrypt Validation Doesn’t Pass


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
slyy.testapp.win
I ran this command:
./letsencrypt-auto certonly --agree-tos --renew-by-default --manual --preferred-challenges=dns

It produced this output:

Please deploy a DNS TXT record under the name
_acme-challenge.slyy.testapp.win with the following value:

69jYN9xctvHD46eHWdF16tRBAfDReRtHFAmTyXl9QKE

Before continuing, verify the record is deployed.

it always failed,I have tried append TXT value to the _acme-challenge.slyy.testapp.win
My web server is (include version):

I didn’t install it yet,I suppose to install tomcat 8.5

The operating system my web server runs on is (include version):
CentOS 7.5
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2


#3

Hi,

What’s the exact error message you got?

Thank you


#4

Failed authorization procedure. slyy.testapp.win (dns-01): urn:acme:error:dns :: DNS problem: NXDOMAIN looking up TXT for _acme-challenge.slyy.testapp.win

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: slyy.testapp.win
    Type: None
    Detail: DNS problem: NXDOMAIN looking up TXT for
    _acme-challenge.slyy.testapp.win


#5

It’s a simple mistake due to a confusing user interface.

You added:

_acme-challenge.slyy.testapp.win.testapp.win. 589 IN TXT "69jYN9xctvHD46eHWdF16tRBAfDReRtHFAmTyXl9QKE"

So what you need to do, is just use this as the “host” in the DNS editor:

_acme-challenge.slyy

instead of the full string that Certbot tells you.


#6

thanks ,Oh What a ridiculous mistake I have done,what a stupid mistake I have done,thank you very much


#7

I have made it,thanks a lot


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.