DNS problem: NXDOMAIN looking up A for itmetommy.com


#1

Please fill out the fields below so we can help you better.

My domain is:
itsmetommy.com

I ran this command:
./certbot-auto --apache

It produced this output:
Failed authorization procedure. itmetommy.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: NXDOMAIN looking up A for itmetommy.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: itmetommy.com
    Type: connection
    Detail: DNS problem: NXDOMAIN looking up A for itmetommy.com

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My operating system is (include version):
CentOS release 6.8 (Final)

My web server is (include version):

/usr/sbin/httpd -v

Server version: Apache/2.2.15 (Unix)

My hosting provider, if applicable, is:
Personal iMac at home running on VirtualBox.

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no


#2

See the difference? Look good :wink:


#3

Wow. How did I miss that? Thank you so much. It works perfectly now. Thanks again @Osiris.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.