Dns-problem http-01

My domain is:
I ran this command:
sudo certbot --apache
It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter 'c' to cancel): saglik-bakanligi.tk
Requesting a certificate for saglik-bakanligi.tk
Performing the following challenges:
http-01 challenge for saglik-bakanligi.tk
Enabled Apache rewrite module
Waiting for verification...
Challenge failed for domain saglik-bakanligi.tk
http-01 challenge for saglik-bakanligi.tk
Cleaning up challenges
Some challenges have failed.


  • The following errors were reported by the server:

    Domain: saglik-bakanligi.tk
    Type: dns
    Detail: DNS problem: NXDOMAIN looking up A for saglik-bakanligi.tk

    • check that a DNS record exists for this domain

How can i fix this problem?

1 Like

The tk nameservers are claiming that your domain does not exist, but the tk WHOIS servers claim that it does.

As a result, nobody can resolve your domain, including Let's Encrypt.

Something has probably gone bad on the registrar side (Freenom).

You should login there and make sure the domain is not expired or anything. Failing that, you might need to contact Freenom to find out what happened.


Thanks for your answer. I bought the domain name yesterday. Valid until 2021


Also, the problem that @_az identified is the reason for the error

and that definitely needs to be fixed before you can get your certificate.

However, something else you might want to look at after that

This part happens when you don't have an existing Apache VirtualHost specifically for the name that you're trying to get a certificate for. In that case (although you'll have to fix the DNS issue as well!) it could be helpful to create an Apache VirtualHost in your Apache configuration that refers to this name, instead of just using the default Apache VirtualHost. At least, this will help Certbot's Apache support work better.

Did you also enter the IP address pointing to your server somewhere in the Freenom configuration?

Freenom Nameservers connected to my cloudflare

It looks like the Cloudflare records have come through now.

Note that Cloudflare will issue its own certificate automatically. You can still get a Let's Encrypt certificate to protect the connection between Cloudflare and your server, or you can use a certificate from Cloudflare's origin CA:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.