Create a certificate micollab-sla.sla.it


#1

Hello with the present I ask you how I can activate a certificate for a product mitel
In the product mitel I have a part where I ask for the certificate but after about 1 minute I get an error
I would like to understand if it is a connection problem or else in this case I am attaching the request to understand how to receive the files to be included in the sw for the management of the certificate I need

I have to certify micollab-sla.sla.it
is server linux

Waiting for your welcome reply I offer you my best regards and I wish you a good job

I await info is quite urgent

if you want I can give you the CSR that generates me the machine the product is mitel and it should be done automatically
you can help me out of courtesy it’s really urgent

sorry if I created two conversations.
n these days and last week I tried several times to do the procedure automatically but always with a negative result, I think the request has also arrived because then I found myself stuck for too many attempts you can check? and if possible can you give me the file to upload them autonomously?
can I somehow send you the CSR?
I’m really stuck with some services I kindly ask you for a quick reply
thanks again and good work to all of you


Creation of a certificate for a mitel service
#2

What is the exact error you’re getting?


#3


#4

Heyho,
seems that you misconfigured your http host. I get only a timeout on http and https redirects to “https://micollab-sla.sla.it/server-manager” with an 500 error.

You should point the http domain to your “www/html” directory. After that check your admin panel again.


#5

but if I have the .txt file can I activate the certificate directly from the site and then upload the files?
but have you seen my requests on your servers?


#6

excuse my ignorance but what do you mean when you write:
You should point the http domain to your “www/html” directory.the machine can not be reached via ping, it only serves for a telephone service that remains hidden under various protections


#7

Ok,
in that case, i think i know where the problem is.

You installed certbot on your server?
If so, which authentication method you choosed, webroot?

Normally, certbot will get you the certificate. Therefore you have to choose one of the provided authentication methods. (Like webroot, dns, etc.)

But it seems based on your missing webserver setup and wrongly choosen “webroot” method, certbot isn’t able to verfiy that you are the owner of the domain.

According to the documentation, u should choose dns or standalone.

Have a closer look at: https://certbot.eff.org/docs/intro.html#how-to-run-the-client

Regards.
Sebastian


#8

He uses a control panel as you can see from his screenshot.

@ggritti It appears your webserver isn’t accessible on port 80. I’m sure your Mitel control panel has some sort of webserver configuration part. Could you check it out and post one or more screenshots about the webserver configuration? And if you could, also the firewall section(s)? It could be a firewall problem too.


#9

@Osiris Yup saw that, but i don’t know the “Mitel” panel. That’s why i asked if he installed certbot him self or if it was delivered with the panel. :wink:


#10

I’m sorry, but I don’t see a reference to certbot anywhere in this thread, but from you. There are many more ACME clients beside certbot out there.

Although I believe you mean the best, I think it’s best to keep the advice clear from any assumptions, so we can help the thread starter best.


#11

this error has been given to me now, and I still do not understand if my request arrives and then I will not be sent back or what’s happening again sorry for the trouble

Problem connecting to server (get for https://acme-v01.api.letsencrypt.org/acme/challenge/Of7T8-YD6rZ20KYp0peBmPsbUxz9MkdAGh4Yl-Wz7sk/7542947181; curl returned with 7)

the request starts from the panel when I click certificate request and automatically points to let’s, that’s why I ask this information to understand where it could stop the whole thing


#12

Hi @ggritti

there is

  • no port 80 configured
  • a running port 80, but a firewall blocks that

But you are using a program. So you have to fix the problem in your program.

Please share the options under “Port forwarding”. If you don’t forward port 80, then this may be one problem.


#13

so is port 80 closed to my program? or the problem is after the firewall according to you? but my request is coming to you?


#14

I can’t see that from outside. It may be a blocking firewall, so that port 80 is visible internal. Or there is no program listening on port 80.

Letsencrypt want’s to load a file like

http://micollab-sla.sla.it/.well-known/acme-challenge/iXVRAlIiyEtsTflWziYQMDOLCzQahvS-szqEVEu79E4

to check if you are the owner of this domain. But can’t - timeout.

I see the same timeout. So please share your page “Port forwarding”:

Do you have shell access? Something like a console? If yes, try

ss -l -n -t

to show all listening ports (numbers, tcp only).


#15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.