Crash when using plesk


#1

Hi im use plesk and when i try to create new certificate (crash)…
. Starting new HTTPS connection (1): 127.0.0.1
Cleaning up challenges
An unexpected error occurred:
KeyError: ‘site’

Please see the logfiles in /opt/psa/var/modules/letsencrypt/logs for more details.
2017-03-05 20:30:52,652:DEBUG:letsencrypt_plesk.api_client:Plesk API-RPC request: <?xml version="1.0" ?>poupee.com
2017-03-05 20:30:52,653:INFO:requests.packages.urllib3.connectionpool:Starting new HTTPS connection (1): 127.0.0.1
2017-03-05 20:30:52,681:DEBUG:requests.packages.urllib3.connectionpool:“POST /enterprise/control/agent.php HTTP/1.1” 200 None
2017-03-05 20:30:52,682:DEBUG:letsencrypt_plesk.api_client:Plesk API-RPC response: <?xml version="1.0"?>


error
1006
Access to API is disabled for 127.0.0.1

2017-03-05 20:30:52,685:DEBUG:certbot.error_handler:Encountered exception:
Traceback (most recent call last):
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/certbot/auth_handler.py”, line 111, in _solve_challenges
resp = self.auth.perform(self.achalls)
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/letsencrypt_plesk/configurator.py”, line 77, in perform
responses.append(self.plesk_challenges[domain].perform(x))
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/letsencrypt_plesk/challenge.py”, line 28, in perform
self._init_domain_props()
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/letsencrypt_plesk/challenge.py”, line 52, in _init_domain_props
api_result = response[‘packet’][‘site’][‘get’][‘result’]
KeyError: ‘site’

2017-03-05 20:30:52,685:DEBUG:certbot.error_handler:Calling registered functions
2017-03-05 20:30:52,685:INFO:certbot.auth_handler:Cleaning up challenges
2017-03-05 20:30:52,686:DEBUG:certbot.main:Exiting abnormally:
Traceback (most recent call last):
File “/opt/psa/var/modules/letsencrypt/venv/bin/certbot”, line 11, in
sys.exit(main())
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/certbot/main.py”, line 882, in main
return config.func(config, plugins)
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/certbot/main.py”, line 608, in run
action, lineage = _auth_from_available(le_client, config, domains, certname)
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/certbot/main.py”, line 108, in _auth_from_available
lineage = le_client.obtain_and_enroll_certificate(domains, certname)
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/certbot/client.py”, line 294, in obtain_and_enroll_certificate
certr, chain, key, _ = self.obtain_certificate(domains)
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/certbot/client.py”, line 265, in obtain_certificate
self.config.allow_subset_of_names)
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/certbot/auth_handler.py”, line 73, in get_authorizations
resp = self._solve_challenges()
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/certbot/auth_handler.py”, line 111, in _solve_challenges
resp = self.auth.perform(self.achalls)
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/letsencrypt_plesk/configurator.py”, line 77, in perform
responses.append(self.plesk_challenges[domain].perform(x))
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/letsencrypt_plesk/challenge.py”, line 28, in perform
self._init_domain_props()
File “/usr/local/psa/var/modules/letsencrypt/venv.lUY3p/lib/python2.7/site-packages/letsencrypt_plesk/challenge.py”, line 52, in _init_domain_props
api_result = response[‘packet’][‘site’][‘get’][‘result’]
KeyError: ‘site’


About the Help category