Connection Refused When Requesting for New Certificate

My domain is:

I ran this command: sudo ./

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /var/www/certbot for all unmatched domains.
Waiting for verification...
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Some challenges have failed.

 - The following errors were reported by the server:

   Type:   connection
   Detail: Fetching
   Connection refused

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.

My web server is (include version): nginx:1.15-alpine (Used as image in docker)

The operating system my web server runs on is (include version): CentOS Linux 7 (Core)

My hosting provider, if applicable, is: dotPH

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I am using docker with my Rails Application.

1 Like

Hi @CharlotteDS

there is a check of your domain, two days old -

Domainname Http-Status redirect Sec. G -2 1.800 V
ConnectFailure - Unable to connect to the remote server -2 1.796 V
ConnectFailure - Unable to connect to the remote server -2 1.813 V
ConnectFailure - Unable to connect to the remote server

Only blocked connections.

If you want to use http validation, a running webserver and an open port 80 are required.

should answer with a http status 404 - Not Found.

1 Like

I only followed this article:

I already have a working application. I added a link between my app and nginx in the docker-compose.yml.


is another user. Same tutorial, same problem.

Perhaps the tutorial is incomplete.


I already solved the issue.
I accidentally erased a word in the configuration file.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.