Connection is not private


Hi there,

I’ve recently moved my website from fasthosts hosting to home server.
I’ve tested everything on a different domain, where everything worked fine.
I don’t know what could be the reason for getting the following message in browsers: This connection is not private.
Could it be because I had a different SSL cert from fasthosts, or any other reason ?
I’ve tried to renew a few times, so now I’ve reached the limit as well.

See details below

Host operating system ubuntu 18.04
web server apache latest in alpine docker container

After checking is the cert was created I got the followings


Thank you


Hi @boxyvision,

The browser error that I see shows the reason for this problem:

The certificate is only valid for

For certificate purposes, and are separate names and both should be listed explicitly in your certificate.

On your new server, generates an immediate redirection to, which then produces the above error.


Your certificate is only valid for - you would need to create a new one that includes both and How did you obtain this certificate in the first place? Doing the same thing over and over won’t change results, just hit rate limits. The good news is you can probably issue a new one for both names, as it won’t be identical to the ones you’ve issued so far (which is probably the rate limit you hit - five identical certificates per week.)


Thank you very much for your quick support! I’ve deleted the old certificate, and created a new one. It works properly! I don’t know , how I did such basic mistake.
You guys are fast & fantastic !


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.