Cloudflare sites give error 502 when I submit my Let's Encrypt-powered sites



I’m new to the community, so - hello guys :slight_smile:

First off, Let’s Encrypt is excellent. A-grade protection for a too-good-to-be-true price tag, which is free :smiley:

Now, I have a slight issue: I run blogs, and usually submit my URLs to bookmarking sites like The thing is, since I migrate my site to HTTPS (with SSL certificate from Let’s Encrypt) the site gives error 502 (bad gateway). uses Cloudflare, and I notice that submitting to other sites using Cloudflare give the same error message.

Another blog of mine is using Comodo SSL, and it’s working fine with the site - so I came to a (noob) conclusion-slash-question: Is this due to my Let’s Encrypt SSL misconfiguration or compatibility issues?

Please kindly advise. For testing purpose, one of my sites that use Let’s Encrypt is I use SSL checker, and all is fine. I’m quite confused.

Many thanks :slight_smile:


Usually when sites have trouble checking on URLs that use Let’s Encrypt, it is because the web site uses Java and is running an old version of the Java Runtime Environment that does not have the correct certificate authority installed. Unfortunately the only way to resolve this is to contact the site in question and get them to update their JRE. (The certificate was added in Java 7u111+ and 8u101+.)

It seems unlikely that CloudFlare has anything to do with it as many people use Let’s Encrypt behind CloudFlare. If you’re seeing a 502 error generated by CloudFlare when submitting URLs, it is probably because their web application doesn’t handle the error it encounters properly and crashes without returning a response to CloudFlare, who then shows you an error message.


That explains a lot. I’ll contact the sites regarding the tech issues.

Many thanks for your help!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.