Cloud Linux - Having Issues with Install

Please fill out the fields below so we can help you better.

My domain is: (not a live site, hosted but doesn’t have a real domain)

I ran this command: wget chmod a+x certbot-auto

It produced this output:

–2016-12-08 14:15:59--
Connecting to||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 44442 (43K) [text/plain]
Saving to: `certbot-auto’

100%[======================================>] 44,442 --.-K/s in 0.1s

2016-12-08 14:16:00 (314 KB/s) - `certbot-auto’ saved [44442/44442]

njbtest@cloud09 [~]# chmod a+x certbot-auto

My operating system is (include version): Apache+LiteSpeed combination being our handler! (from hosting provider)

My web server is (include version): Our shared servers run off of CloudLinux as the OS

My hosting provider, if applicable, is:

I can login to a root shell on my machine: Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel 60.0.24

Ran the command and got the output as seen when to run the following command after (thought I was following the guide)

$ ./path/to/certbot-auto --apache

Only get this as output after

-bash: $: command not found

Completely lost on what I should be doing/have done wrong, any help would be greatly appreciated!

Since you are using cpanel, I’d suggest using AutoSSL ( a function within cpanel) to install the certs for you.



Thanks for the info, that’ll be rather handy!

I’m running on a shared server, I’ve asked if I can have root access but doubt it, if that’s the case what’s the next best option?

OK, I took your initial response of ;

to assume you did have root access. On a shared server you won't be allowed root access.

  1. I'd ask your host if they are willing to turn AutoSSL, with Let's Encrypt, on for your domain.

  2. If they don't do that, is there an option in your cpanel for uploading a new SSL certificate ( again it will depend if your host has enabled it).

  3. If option 2 isn't available, then you need to ask them if they will install the certificate for you (ideally for free, otherwise it starts to cost a lot).

1 Like

and if they won't assist you could move to a host that supports LE, there are quite a few

Ahhh apologises I should have been more specific!

I’d been talking with them throughout the day about trying to install a certificate through ssh and they did mention they’re rolling out updates to support lets encrypt soon, just asked them if that means the auto-ssl feature but I presume it does.

I do have the ability to install certificates myself. A couple months back I tried installing one myself as a test, ended up fluffing it up royally so had just been buying them since.

There are a number of ways forward then.

  1. you can just wait for your host provider to support Let’s Encrypt (it’s pretty much a single command for them to turn it on in cpanel).

  2. You use the one you bought, until 1) happens ( this depends when your current SSL cert expires).

  3. you could obtain a Let’s Encrypt certificate and manually install it in cpanel ( in exactly the same way as I assume you do with a purchased cert).

1 Like

Sorry for the slow reply, I got hit hard with a winter illness!

Thanks for the advice, I think I’ll give option 3 a go since I’ve been through it before. Hosting provider has said lets encrypt will be supported by end of Jan so after then hopefully will be a simple process.



1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.