Certificate was issued but the site is still unsafe inn HTTPS: https://whn-analytics.net/long_covid/index.html

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: who-analytics.net

I ran this command: sudo certbot -n -d whn-analytics.net --nginx --test-cert --agree-tos --email olha@necsi.edu

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version): Linux 2023

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): I connect to my site via SSH.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot-auto --version is turned off

This is why your site is unsafe; this option issues certs from an untrusted certificate authority for testing purposes only.

5 Likes

Which is it?
[my guess is that it is the first one]

3 Likes

I guessed incorrectly:

4 Likes

Thank you! Is there a way to replace the certificate?

2 Likes

This worked for me! sudo certbot -n -d whn-analytics.net --nginx --agree-tos --email olha@necsi.edu certonly --force-renew

1 Like

Going forward you only need to use:
certbot renew
[which should be in a daily scheduled cron type job]

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.