Certificate Revoked

There are a lot of threads about revoked certificates however I cannot seem to find what to do when this has happened… Can I now never use the domain name anymore?
And I do not know why it has been revoked in the first place!
I really do not know what to do and in the meantime mail and site are down.
What are the steps I need to take to get the revoked certificate off?
Thanks!!!

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: dm.dekom.be

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):Synology

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Yes, Synology devices have sometimes been revoking their own certificates recently. Check out this post:

Edit:

Looking closer, you have one unexpired certificate that was revoked recently:

https://crt.sh/?id=1818198607&opt=ocsp

And three that have not been:

https://crt.sh/?id=1818198380&opt=ocsp
https://crt.sh/?id=2003849901&opt=ocsp
https://crt.sh/?id=2004582552&opt=ocsp

2 Likes

Hi mnordhoff,
This was exactly what I needed: Short and informative answer!
All is solved in a easy way.
Thank you very much for your help.

2 Likes

@Mikerosoft

I had the same issue. Synology has released a DSM patch that seems to have fixed the issue for me. I put the details here: Certificate Revoked Error

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.