Certificate registration

I have used a certificate on a router for several years, but have just changed the device. I cannot get that certificate to register or authorise on the tne router. I can create another and switch between that and another new one but cannot get the original to work again. Is there any way deleting or reassigning certificates? It has now resulted in having to create new domain names and all the associated reprogramming of other applications.

1 Like

Hi @nscnick

a Letsencrypt certificate, a self signed?

Please answer all of the following questions:


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

1 Like

Hi I replied to the email (as it says) but it was returned with:

We’re sorry, but your email message to [“ letsencrypt+f193c3c0a510c55c96a2991d967a6e97@discoursemail.com ”] (titled RE: [Let’s Encrypt Community Support] [Help] Certificate registration) didn’t work.

Reason:

Sorry, new users can only put one image in a post.

If you can correct the problem, please try again.

1 Like

Hi Juergen

I sent this to the reply to which was rejected!

Let’s Encrypt certificate.

NSCDESIGN.ASUSCOMM.COM. which would not and does not work on the new router.

Since created NSCADVENTURES and NSCOUTDOORS both on .ASUSCOMM.COM, both of which do work and I can switch between them. Currently the NSCOUTDOORS is the one set on the router. I tried both to see what would happen as part of diagnostics.

Controls for these are through the ASUS GUI, which has been check updated on installation over the last weekend.

When I set up the new router it told me that NSCDESIGN was already registered, but wouldn’t authorize or update the certificate, and still won’t. The other two are fine.

Does this mean that the certificate embeds some reference from the physical device, in which case I can see that it may not work, but I would have thought it should still update? I would prefer to reuse NSCDESIGN. I couldn’t see any facility on your website to delete, reuse, or otherwise modify certificates.

Regards

Nick Cole

1 Like

A certificate isn’t device specific. It has only domain names (one or more)

If there is such a limitation, it’s a limitation of the ASUS GUI.

So check the documentation of that ASUS GUI to find a solution.

May be you can register such a subdomain name yourdomain.asuscomm.com only with one device. But that’s an ASUS limitation.

1 Like

Hi Juergen. There may well be device specific limitations but that is not what I was querying. Having entered the old domain in the new router it refused to update/authorize. In principle it should have at least allowed that ‘certificate’ domain to be reused, but it didn’t. And entering it stated that it was already registered, on the new router it wouldn’t have known that without accessing some external system. The new ones can be used but NSCDESIGN cannot. Which is why I queried the lack of deletion or forced reauthorising facility on your management website.

Regards

Nick

Let’s Encrypt does not prevent you from issuing duplicate certificates from the same device or multiple devices. (They do rate limit extreme behavior, though.)

The Certificate Transparency logs do not have a record of any certificates for nscdesign.asuscomm.com.

What is the exact error message? From what you’ve described, it doesn’t sound like something from Let’s Encrypt.

Edit: There are certificates for nscadventures.asuscomm.com and nscoutdoors.asuscomm.com.

May be you should not create as a new domain, because it is already created? You may have the credential of that old domain to apply to the new device.

I am just guessing, I have absolutely no any vendor specific information.

Many thanks. I will try nscdesign again then. Is there a facility to cancel certificates not or no longer needed? outdoors and adventures were created as part of a diagnostic process.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.