Certificate on multiple instances of AWS for the same domain


#1

I used Let’s Encrypt to get a certificate for my domain and everything worked perfectly. I then linked my domain with a different instance on AWS and used let’s encrypt to get a certificate again on the same domain (because I needed the actual certificate to be located in that server, so I figured I would just get a new one there). However, after that I was unable to access the domain - the connection is refused. I tried to revert back to the previous instance where everything was working, but the connection was still refused even when I changed back. I just renewed my certificate in that instance and it still does not load anything to my domain. Is there any problem with having multiple certificates for the same domain over multiple instances? How would I go about fixing this, on either my new instance or my old one? Any feedback would be greatly appreciated!
In case you’re curious, my domain is zeus.uiuc-bdeep.org


#2

Hi,

I don’t think the problem is from your certificate…

Can you share us some information by filling in this form?

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

P.S. my best guess is you have not configured the security group (on AWS control panel) or firewall (on your server) properly.
Currently you only have port 22 /ssh open.

Thank you


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.