Website inaccessible


#1

Hi: I was trying to resolve the certificate deprecation issue and I created a copy of my instance on Amazon Lightsail I the fixed both instances by updating them via sudo apt-get full-upgrade and refreshed the certificates which all seemed to work. However, I think I messed up by pointing my domain to the new instance and now both sites are inaccessible. Any help would be appreciated.

My domain is: www.mathmusings.org/webwork2

I ran this command:

It produced this output:

My web server is (include version): Apache2

The operating system my web server runs on is (include version): Ubuntu 16

My hosting provider, if applicable, is: Amazon Lightsail

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No


#2

Works fine for me, with SSL.


#3

When I use https://34.203.69.82/webwork2 my browsers tell me the site is not secure but I can still access it by adding an exception. If I use http://www.mathmusings.org/webwork2 my browers don’t access it at all and I’m timed out. I think I messed up stuff by pointing the domain name to a different IP address then switching it back.


#4

Okay.

Just trying to be clear.
You have tried to switch to the EC2 machine, and for some reason the domain does not connect, right? (Is there an message for that?)

Then, you switched the DNS back to the old machine?

Because now, both @_az and I can confirm that your website is up and running.

Thank you


#5

Wait. It seems to be working now. Like I said I think I messed up stuff when I switched the IP addresses. I’m not very good with this stuff and I think it takes a while for all the tables to get updated when you do that. In general is it safe to point your domain name to a different istance with a different IP address and not mess up the certificates?


#6

Yes. You just need to take a few hours for all global DNS resolvers to propargate.

Thank you


#7

Right. I paniced for a bit when my site was not accessible. Thank you so much for your patience.


#8

The cert will not cover any IP.
So don’t use an IP in the URL (only covered FQDNs are allowed).


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.