Certificate not activating

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: http://polaarenergy.com

I ran this command: trying to install certificate from Plesk.

It produced this output: Error: Could not issue a Let’s Encrypt SSL/TLS certificate for polaarenergy.com .

The authorization token is not available at http://polaarenergy.com/.well-known/acme-challenge/svC1HIVtS0I7FKmZiA72zGu5lGMobBV3v5xD_7-jWp0.
To resolve the issue, make sure that the token file can be downloaded via the above URL.
See the related Knowledge Base article for details.
Details

Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz/sdh9iz89j2pAaKKUjC1GiPfExoic_s3f_hEq0m_SL3Q.
Details:
Type: urn:ietf:params:acme:error:unauthorized
Status: 403
Detail: Invalid response from http://polaarenergy.com/.well-known/acme-challenge/svC1HIVtS0I7FKmZiA72zGu5lGMobBV3v5xD_7-jWp0 [109.238.10.122]: “\n\n404 Not Found\n\n

Not Found

\n<p”

My web server is (include version): I don’t know.

The operating system my web server runs on is (include version): I don’t know.

My hosting provider, if applicable, is: I don’t know.

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Onyx 17.0.17

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): -

Hi @marketon

checking your domain via https://check-your-website.server-daten.de/?q=polaarenergy.com there is no error visible.

Domainname Http-Status redirect Sec. G
http://polaarenergy.com/
109.238.10.122 200 0.070 H
http://www.polaarenergy.com/
109.238.10.122 200 0.074 H
https://polaarenergy.com/
109.238.10.122 -4 0.124 W
SendFailure - The underlying connection was closed: An unexpected error occurred on a send. The handshake failed due to an unexpected packet format.
https://www.polaarenergy.com/
109.238.10.122 -4 0.483 W
SendFailure - The underlying connection was closed: An unexpected error occurred on a send. The handshake failed due to an unexpected packet format.
http://polaarenergy.com:443/
109.238.10.122 200 0.077 Q
http://www.polaarenergy.com:443/
109.238.10.122 200 0.070 Q
http://polaarenergy.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
109.238.10.122 404 0.066 A
Not Found
Visible Content: Not Found The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. Apache Server at polaarenergy.com Port 80
http://www.polaarenergy.com/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
109.238.10.122 404 0.067 A
Not Found
Visible Content: Not Found The requested URL /.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de was not found on this server. Apache Server at www.polaarenergy.com Port 80

The /.well-known/acme-challenge/random-filename answers with the expected http status 404 - Not Found.

But: Plesk is a closed world. So it should work.

If it doesn’t work -> ask your hoster.

One thing is curious: Your http + / sends:

X-Powered-By: PleskLin

But /.well-known/acme-challenge doesn’t send that header, instead, there is the standard Apache “Not Found” message.

Do you have added additional definitions Plesk doesn’t understand?

Or your hoster catches /.well-known/acme-challenge, so this Plesk-Header isn’t sent.

Thanks for the fast reply. So basically I need to contact the hosting company. Nothing to do for me?

Yes, ask your hoster. Plesk -> closed world.

And check the list:

If the server contains custom rewrite rules, disable them by renaming .htaccess file or web.config . Also, remove custom rewrite rules from Plesk > Domains > example.com > Apache & nginx settings .

and

Make sure that the Run the website in compatibility mode for the legacy option "Separate SSL/TLS and non-SSL/TLS content Plesk > Domains > example.com > DNS Settings option is not enabled in Plesk > Tools & Settings > Domains > example.com > Hosting Settings

looks critical.

Thanks a lot! I’ve contacted them and now the problem is solved!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.