Certificate Expired

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: chenpuguang.com

I ran this command: Install an SSL Certificate on a Domain

It produced this output: Certificate Expiration

You should request a replacement certificate from the issuer (Let’s Encrypt) as soon as possible.

A certificate that remains active after its expiration date will generate security warnings in users’ web browsers.

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Hostgator

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): 78.0.46

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): Don’t know

1 Like


Are you using HostGator’s shared hosting product?
If so, your certificate should be issued from cPanel (or Let’s Encrypt) automatically.

How did you get the certificate at first?

Thank you

1 Like

Hi @johnchen

checking your domain there is no error visible - https://check-your-website.server-daten.de/?q=chenpuguang.com

The certificate is new:

expires in 84 days	autodiscover.chenpuguang.com, chenpuguang.com, 
cpanel.chenpuguang.com, mail.chenpuguang.com, 
webdisk.chenpuguang.com, webmail.chenpuguang.com, 
www.chenpuguang.com - 7 entries

non-www and www use that certificate, no critical mixed content.

It produced this output: Certificate Expiration

Do you have an old browser cache?

Or share a screenshot of the problem.

PS: You don’t have a redirect http -> https. So if a user uses http, it’s insecure. But that’s a different error message.

And your https doesn’t work:

Fatal error : Call to undefined function trailingslashit() in /home/ziji2015/public_html/wp-content/plugins/lfjmonetizeme/options/defaults.php on line 0

Warning : Cannot modify header information - headers already sent by (output started at https://chenpuguang.com/wp-content/plugins/lfjmonetizeme/monetizeme-options.php:3) in /home/ziji2015/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 1338

Fatal error : Call to a member function get() on null in /home/ziji2015/public_html/wp-content/plugins/lfjmonetizeme/inc/addcentsfuncs.php on line 0

But the certificate is valid, that’s a problem of your application.


Hi Steven,

Thanks for your kind reply.

Yes, I use Hostgator and tried for the first time to install SSL onto a domain that I’ve had for years.

I was unsure after getting the SSL process into action when seeing the error message saying that the certificate expired and therefore, have not pressed the “install” button yet.

1 Like

Hi JuergenAuer,

Thanks for your kind help with such expertise indeed.

I’ve not pressed the “install” button due to uncertainty what might happen.

Please kindly see the attached screen shot herewith.

Perhaps I should press “install” and see what might happen… :slight_smile:

Many thanks again…

Please don’t…
Please login to your cPanel. (cPanel, the port ends in 3083) instead of your WHM.

In cPanel, there’s a choice said “Manage SSL/TLS Certificates” or “AutoSSL” feature.
Or you can use the below tutorial to run AutoSSL (request certificates) for all users.

Thank you

1 Like

Hi Steven,

I mis-read the message thinking that I should go ahead and then this is what is being shown…

By the way, I can’t find this in my cpanel…many thanks again…

Please try to find AutoSSL in your WHM panel, and run it for your account.

Thank you

1 Like

Thanks, Steven…I’m looking for it as we speak… :slight_smile:

1 Like

Hi Steven and JuergenAuer,

I contacted support at Hostgator and the issue has been fixed now.

Thanks so much for your kind help, guys…

Much appreciated indeed.

Wow, this is such a great forum I’m amazed.

Best regards,

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.