Certficate not valid

Hello, i installed my server and site using the one click wordpress server install from digital ocean https://marketplace.digitalocean.com/apps/wordpress?ipAddress=159.65.64.214#getting-started

It installed certbot and i prompted my domain to install de certificate, everything said it was done correctly but when i acces my site it says that the connection is not safe even though it shows a valid certificate.

My domain is: www.garlana.com.mx

1 Like

Hi @AndreaMaraca

checking your domain your certificate is valid - https://check-your-website.server-daten.de/?q=garlana.com.mx

The certificate

CN=garlana.com.mx
	24.09.2020
	23.12.2020
expires in 87 days	garlana.com.mx, www.garlana.com.mx - 2 entries

has both domain names. So it's not a certificate problem.

But you have some http resources included. That's mixed content. See the #Html-Content - part.

Sample:

http://garlana.com.mx/wp-content/uploads/2020/09/GARLANA-ISOTIPO.png

Change these to https, your WordPress should have an option to do that.

1 Like

Hello @AndreaMaraca

@JuergenAuer has given you a head start.

My count shows 37 references to non secure links being served by www.garlana.com.mx

This could be something you'll need to correct in the WordPress theme itself with which is a bit of a pain. (I doubt that this is the case but I have seen it before)

OR it is more likely it might be as simple as adjusting your GENERAL SETTINGS and PERMALINK SETTINGS within the admin section of WordPress.

Your general settings should look something like this:

Then verify your permalinks in settings area to fit what you want your URL to look like in the browser and for SEO compatibility..

Hope this helps.

3 Likes

thanks you are right! Gonna work on correcting it

Thanks Rip i already did that and it seems like the problem are some of the images :confused: which are http

No, never.

That's the namespace declaration, not a link to include a resource.

Most Namespace declarations are http links. Changed to https -> unknown namespace, nothing would work.

Thank you.

However, http://www.w3.org/2000/svg redirects to https://www.w3.org/2000/svg anyway.

In my experience it is faster and cleaner for the browser to link to https://www.w3.org/2000/svg namespace or any other "namespace" that is a secured resource via https directly.

"Your mileage may vary"

That's unrelevant.

A Xml Namespace is an unique string, nothing else.

http**://www.w3.org/2000/svg
htt://www.w3.org/2000/svg
ht123://www.w3.org/2000/svg
www.w3.org/2000/svg
urn:schemas-microsoft-com:office:office

All these strings are valid namespaces. Last is one from Microsoft with a completely different schema.

So a namespace string may start with http or https. But it's unrelevant if the address exists, if there is a webserver or a redirect.

If a namespace string starts with http / https, the address is never checked.

PS: But if the namespace is defined with http, https is another namespace -> nothing works.

@JuergenAuer
Thank you. I appreciate you pointing this out.
W3.org supports your observation.

@AndreaMaraca,

As of today I continue to get a count of 37 insecure references.

31 of the 37 insecure references I mentioned are for Scalable Vector Graphics (SVG) pointed at http://www.w3.org/2000/svg.

These references are valid as pointed out by @JuergenAuer, verified at https://www.w3.org/TR/2011/WD-html5-20110525/namespaces.html and
should not be altered.

If, as you stated, your WordPress general settings and permalinks are correct, then grab a good text editor and search your template for http:// (that don't point to "namespace resources") and replace them with https://

In any case, you have your LE certificate and it is working.

Please contact https://www.8theme.com/ if you need additional support with your theme

OR https://wordpress.org for support with your CMS, if required.

Of course, this forum always supports issues that are directly related to LE certificates, renewals, etc.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.