Certbot renew not working in Lightsail Apache server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: lamer-skin.com

I ran this command: sudo certbot renew

It produced this output:

My web server is (include version): Apache
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/lamer-skin.com.conf


Cert is due for renewal, auto-renewing...
Could not choose appropriate plugin: The manual plugin is not working; there may be proble
ms with your existing configuration.
The error was: PluginError('An authentication script must be provided with --manual-auth-h
ook when using the manual plugin non-interactively.')
Attempting to renew cert (lamer-skin.com) from /etc/letsencrypt/renewal/lamer-skin.com.con
f produced an unexpected error: The manual plugin is not working; there may be problems wi
th your existing configuration.
The error was: PluginError('An authentication script must be provided with --manual-auth-h
ook when using the manual plugin non-interactively.'). Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/lamer-skin.com/fullchain.pem (failure)


All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/lamer-skin.com/fullchain.pem (failure)


1 renew failure(s), 0 parse failure(s)

The operating system my web server runs on is (include version): Amazon Lightsail Apache server

I can login to a root shell on my machine (yes or no, or I don't know): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.31.0

2 Likes

Hi @muhammadZihad, and welcome to the LE community forum :slight_smile:

Your last renewed/obtained the cert using --manual authentication.
[which can't be automated (without manual intervention/processing)]

2 Likes

How can I solve this problem? Is there any documentation or something?
And thank you very much for your reply

1 Like

Hi @muhammadZihad,

This is a relatively frequent topic on this forum, and you should find some prior threads with a lot of detail and some good answers under either of

https://community.letsencrypt.org/search?q=%22certbot%20renew%22%20manual

https://community.letsencrypt.org/search?q=%22an%20authentication%20script%20must%20be%20provided%22

(Feel free to ask more questions if you still have them after consulting those prior threads!)

2 Likes

To supplement the excellent resources mentioned by @schoen:

1 Like