Certbot renew "connection refused"


#1

My domain is: klimapartner.de

I ran this command: certbot-auto renew --dry-run

It produced this output:

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for klimapartner.de
Waiting for verification…
Challenge failed for domain klimapartner.de
http-01 challenge for klimapartner.de

Cleaning up challenges
Attempting to renew cert (klimapartner.de) from /etc/letsencrypt/renewal/klimapartner.de.conf produced an unexpected error: Some challenges h
ave failed… Skipping.

My web server is (include version): nginx/1.10.3

The operating system my web server runs on is (include version): ubuntu 16.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.32.0

my auto renewal worked for some years now. it just stoped working . no changes where made to the server or any software on it…
I can access .well-known/acme-challenge from a browser when putting a test.txt file in it.
Watching the folder with watch -d ls -l i see the challenegs get created…
testfile and challenges have the same access rules owner and group…

p.s.: i renew my certs every month, or at least run “certbot renew” every month on the 22nd.
cert renewal is due on march 31, so i guess the last working renwal must have been in december…


#2

Hi @Holger-Will, welcome to the Let’s Encrypt community forum :wave:

It looks like you have an IPv6 address (2001:8d8:884:c500::44:7dd8) configured for klimapartner.de but requests to port 80 over IPv6 are getting a connection refused error. Likely your webserver isn’t configured to listen on the IPv6 interface of your server.

You can see the problem here in some Let’s Debug output: https://letsdebug.net/klimapartner.de/29278

Do you intend for your site to work over IPv6? If not you could remove the AAAA record with the IPv6 address from your DNS and that would likely fix the problem.

If you want your site to work over IPv6 can you share your nginx config? Perhaps you should also check if there is a firewall rule that might only allow IPv4 port 80 and not IPv6.


#3

thank you very much. that is probably it. i will try now. genius!


#4

that worked! Again: thanks you very much!


#5

Woohoo! Glad to hear it :slight_smile: Thanks for reporting back.


closed #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.