Certbot is unable to deploy me _acme-challenge value for my domain visrtonline.com

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: visrtonline.com

I ran this command: letsencrypt|certbot certonly --manual --preferred-challenges=dns --email admin@visrtonline.com --server https://acme-v02.api.letsencrypt.org/directory --agree-tos -d '*.visrtonline.com' -d 'visrtonline.com'

It produced this output: Certbot doesn't know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run "certbot certonly" to do so. You'll need to manually configure your web server to use the resulting certificate. Press Enter to ContinueAn unexpected error occurred:

My web server is (include version):

The operating system my web server runs on is (include version): cloudfare

My hosting provider, if applicable, is: cloudfare

I can login to a root shell on my machine (yes or no, or I don't know): no

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): yes ( CentOS v7.9.2009 STANDARD kvm

cPanel Version


The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Termius

Hi @letsencerypt, and welcome to the LE community forum :slight_smile:

"Certbot is unable to deploy me _acme-challenge value for my domain ..."

Using --manual requires you to do it all yourself [and that method can't be automated].
What/How have you tried to automate the process?

That said, if you are using CloudFlare, why do you even need an LE cert?
[the more details you provide the better we understand the problem and in turn the better the solution should be]


This is a MX record i need to add to my cloudfare

So... you want a cert for an email system?
If so, what is that FQDN?
Right now, I don't see any MX record for your domain :frowning:


Automate? i used high level of security to host my link using evilginx, How can i do this maually? because it appear i need to deploy the key value generated from _acme-challenge.visrtonline.com to complete my DNS record on cloudfare. which certbot could not deploy.

Then have you considered using another ACME client [that can integrate with Cloudflare DNS API]?


Another ACME? No , regardless this has to be done with certbot using evilginx. it is unusual becuase last time i used it was able to generate a value

You mean what Certbot can also do?

@letsencerypt Please post the output corresponding with the thread title. The output shown now is the one where you didn't yet provide the certonly subcommand, while your command does show it. So clearly the output is not the correct one.

Further more, you should be able to use the Cloudflare DNS plugin to automate the adding and removing of TXT RRs. How did you install Cerrbot?

Also, your hosting provider for the website seems to be DigitalOcean.


We don't even know what version is in use.


As the Cloudflare authenticator plugin is already present in 0.15.0 I think chances are quite good it would be available to OP.




it is a stage and a process, if i cant generate a mx , it will be unstable for me to use on cloudfare

yes cloud fare vps

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.