Certbot: error: unrecognized arguments: ‐‐dry‐run

Hello,

on my raspbian buster when i use the --dry-run option i got the error unrecognized arguments: ‐‐dry‐run

pi@raspberrypi:~ $ certbot renew ‐‐dry‐run
usage:
certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] …

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: unrecognized arguments: ‐‐dry‐run

pi@raspberrypi:~ $ command -v certbot
/usr/bin/certbot

pi@raspberrypi:~ $ certbot --version
certbot 0.31.0

pi@raspberrypi:~ $ apt search certbot | grep installé

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

certbot/stable,now 0.31.0-1 all [installé]
python3-certbot/stable,now 0.31.0-1 all [installé, automatique]

The renew without --dry-run works succesfully

certbot has been reinstalled , raspbian rebooted

Do you have any idea ?

Regards

1 Like

Welcome to the Let’s Encrypt Community :slightly_smiling_face:

Your version of certbot is ancient and has known bugs. Update it and try again.

Hello griffin,

thank you for your help , my cerbot version seems up to date

pi@raspberrypi:/usr/bin $ sudo apt-get install --only-upgrade certbot
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
certbot est déjà la version la plus récente (0.31.0-1).

1 Like

Unfortunately, apt-get may not necessarily let you access the newer versions. I know your OS is Debian 10 Buster. What webserver software are you using?

it seems nginx for Domoticz

1 Like

Perhaps:
sudo apt-get install --only-upgrade certbot python-certbot-nginx

nop :disappointed_relieved:

1 Like

Same result, huh?

While dry run is advisable for testing, it is not a necessary function. Have you tried without dry run?

Seems you have.

Hmm…

@_az

You around? I think you may know this one directly.

Yes without “–dry-run” my certificate has been renewed successfully.

As i don’t want to make mistakes on my domotic system the --dry-run was a useful tool

If someone have an idea

1 Like

@djm38fr

I’ve done some research and seen a few ways this can happen.

@bmw

I found a github thread where you addressed a similar issue that may or may not be correlated. Any thoughts?

Two suggestions:

  1. try typing that in again (slowly and carefully) - do not copy/paste;
    Perhaps there are some characters in there that are not visible to the eye :skull:
  2. Have you tried installing certbot via snaps? (https://snapcraft.io/install/certbot/raspbian)
    That will give you 1.8.0 version.
    [going down this path will require removing the current certbot first - for sanity]
1 Like

Didn’t know whether to recommend that or not. The certbot page for Nginx on Debian Buster does not mention snap. It’s certainly a superb recommendation if it does work though.

edit: If the snapd box were any bigger I would have hit my head on it.

I’m not sure if you glanced at the link I posted to bmw, but it’s possible the OP may have multiple conflicting versions of certbot.

1 Like

Could you please check:

python2 -m pip list | grep -iE "(certbot|letsencrypt)"
python3 -m pip list | grep -iE "(certbot|letsencrypt)"
cat /etc/letsencrypt/cli.ini
1 Like

which certbot
find / -name certbot
crontab -l

Hello,

pi@raspberrypi:~ $ python2 -m pip list | grep -iE "(certbot|letsencrypt)"
/usr/bin/python2: No module named pip

pi@raspberrypi:~ $ python3 -m pip list | grep -iE "(certbot|letsencrypt)"
/usr/bin/python3: No module named pip

pi@raspberrypi:~ $ cat /etc/letsencrypt/cli.ini

Because we are using logrotate for greater flexibility, disable the

internal certbot logrotation.

max-log-backups = 0

I guess your Pi is only a slice of Pi - lol
[no python2, no python3]
Can you show the outputs of?:

pi@raspberrypi:~ $ which certbot
/usr/bin/certbot

pi@raspberrypi:~ $ sudo find / -name certbot
/etc/logrotate.d/certbot
/etc/cron.d/certbot
/usr/lib/python3/dist-packages/certbot
/usr/share/doc/certbot
/usr/bin/certbot

crontab -l
no crontab for pi

and
sudo crontab -l
or
crontab -u root -l

rg305 congratulations !!! typing instead of doing copy/paste WORKS !!!

there is something wrong in my documenentation , thank you all for the help and sorry for this stupid issue

best regards

2 Likes

What you see isn’t always what you get - lol

Very glad to see the “Congratulations” - victory is ours!

You can confirm the cert with:
certbot certificates

Also, don’t forget to check/enable automatic renewals.

2 Likes