Unexpected error: 'server'. Skipping


#1

Hi,

I tried to renew a certificate on Ubuntu 16.04 and Apache for my website. To test it I put in:
sudo letsencrypt renew --dry-run

But I get the following error message:
WARNING:letsencrypt.cli:Attempting to renew cert from /etc/letsencrypt/renewal/myserver.com.conf produced an unexpected error: 'server'. Skipping.

So I tried it with:
sudo certbot renew --dry-run

Then I get:
Command not found

What can I do?

Thank you
Max


Renewal not working - non referenced error - help
Problem renewing the cert in dry-run
#2

This looks to be related to Problem renewing the cert in dry-run

Maybe there is a bug with -dry-run. Can you use verbose mode (-vvv ) and paste the output, and the log


#3

I believe this is a side-effect of switching from a recent release of certbot-auto (or letsencrypt-auto) to the (older) letsencrypt package in Ubuntu 16.04. The older Ubuntu package is not forwards-compatible to configuration files generated by more recent releases. You have a couple of options:

  • Continue using certbot-auto. You can follow the instructions on the certbot homepage for Ubuntu 14.04 - they work just fine on 16.04.
  • Start with a new configuration. The cleanest way would probably to do something like mv /etc/letsencrypt /etc/letsencrypt.old and then re-issue all certificates.
  • Try to manually fix the configuration. This is probably tricky and error-prone. The best way to attempt this would probably be to issue a new certificate with the letsencrypt command first, and then compare the generated config file in /etc/letsencrypt/renewal with the one that’s failing at the moment.

Letsencrypt renew problem
Problem renewing the cert in dry-run
Got 1 day left renew don't work!
#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.