Certbot doesn't seem to allow mail groups (!mailgroup@foo.com)

When using certbot, and using a mail group as the contact email address, certbot disallows the email saying its invalid. Emails starting with ! are valid, are they not?

2 Likes

Welcome to the Let's Encrypt Community, Kris :slightly_smiling_face:

I believe that you are technically correct according to the specification.

@certbot-devs

A de facto restriction on the part of certbot?

2 Likes

Just to clarify, this does seem to be a certbot specific limitation rather than something enforced by Boulder. I was able to set the contact address via my client against Boulder to !test@example.com without an issue.

4 Likes

So, I was using certbot when I found it threw an error.

On my Azure Window's Web Apps though, it seems to accept emails with ! in the name.

But, I'm actually worried its not sending emails to that address. It used to be my email address, and since i've switched it over to the group, my email has been oddly silent.

Got a rough couple weeks as I check the sites manually and frantically it seems...

2 Likes

Use https://crt.sh to search for the certificate issuances for your domains. It will make your life much easier.

2 Likes

This does appear to be a current limitation of Certbot.

I opened https://github.com/certbot/certbot/issues/8595 to track the issue.

6 Likes

For what it's worth, one way to work around the problem for now seems to be setting your email address on the command line rather than interactively.

I think certbot register --email '!mailgroup@foo.com' should work for you.

5 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.