Certbot inactive

Hi please i need help

  • certbot.service - Certbot
    Loaded: loaded (/lib/systemd/system/certbot.service; static; vendor
    preset: enabled)
    Active: inactive (dead) since Sat 2021-03-27 09:05:10 UTC; 2s ago
    TriggeredBy: * certbot.timer
    Docs: file:///usr/share/doc/python-certbot-doc/html/index.html
    https://letsencrypt.readthedocs.io/en/latest/
    Process: 16840 ExecStart=/usr/bin/certbot -q renew (code=exited, stat
    us=0/SUCCESS)
    Main PID: 16840 (code=exited, status=0/SUCCESS)

i don't know what is certbot timer , but i installed it by fault traing to active my certbot !! so i don't know why certbot is always inactive ! also i don't know when i try to use

sudo certbot certonly --standalone --preferred-challenges http --agree-tos --email x.x.x.x -d mail.xxx.tn
it said invalid e-mail address
can somone help me ??

Don't worry about the certbot.service being inactive. It's normal. It's just some jargon related to how systemd works and it's not important to understand.

The important error is:

Since you have redacted your email address:

... it's hard to say why Certbot is complaining. At face value, you have put an invalid email address in.

A valid email address looks something like user@example.com.

If you don't want to put an email address in at all, you can use --register-unsafely-without-email instead of providing an --email. You should provide an email address if you can, though.

1 Like

Note that this is strongly discouraged, because you will be unable to receive notice about impending expiration or revocation of your certificates or problems with your Certbot installation that will lead to failure to renew.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.