Certbot-auto, Oracle Linux and nginx

#1

Hi all, I am trying to set up cerbot-auto on an Oracle Linux machine I have so that it auto renews the cert in nginx, but it doesn’t seem to be working when I run certbo-auto it doesn’t work. I can run certbot but it wants me to do HTTP check, rather than DNS-01 check. I know I am doing something wrong, but do not know what.

I ran this command:

wget https://dl.eff.org/certbot-auto
chmod +x certbot-auto
certbot-auto --nginx

It produced this output:

Total download size: 545 k
Is this ok [y/d/N]: y
Downloading packages:
No Presto metadata available for ol7_latest
wget-1.14-18.el7.x86_64.rpm | 545 kB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Updating : wget-1.14-18.el7.x86_64 1/2
Cleanup : wget-1.14-13.el7.x86_64 2/2
Verifying : wget-1.14-18.el7.x86_64 1/2
Verifying : wget-1.14-13.el7.x86_64 2/2

Updated:
wget.x86_64 0:1.14-18.el7

Complete!
[root@mylinux ~]# wget https://dl.eff.org/certbot-auto
–2019-02-15 06:19:18-- https://dl.eff.org/certbot-auto
Resolving dl.eff.org (dl.eff.org)… 151.101.60.201, 2a04:4e42:f::201
Connecting to dl.eff.org (dl.eff.org)|151.101.60.201|:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 61453 (60K) [application/octet-stream]
Saving to: ‘certbot-auto’

100%[=====================================================================================================================================================================>] 61,453 --.-K/s in 0.005s

2019-02-15 06:19:19 (11.7 MB/s) - ‘certbot-auto’ saved [61453/61453]

[root@mylinux ~]# chmod +x certbot-auto
[root@mylinux ~]# certbot-auto --nginx
bash: certbot-auto: command not found…

My web server is (include version):

nginx version: nginx/1.10.2

The operating system my web server runs on is (include version):

Linux 4.1.12-94.1.8.el7uek.x86_64 x86_64

I can login to a root shell on my machine (yes or no, or I don’t know):

Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

certbot 0.29.1

#2

Hi @AngryDog

use your complete path to certbot-auto.

Or

./certbot-auto
1 Like
#3

Thanks Juergen. I am quite the Linux noob unfortunately.

#4

We all learn (Linux) one step at a time…
Glad to hear you got it working :slight_smile:

But I’m wondering if you have certbot and now also have certbot-auto installed…
As they may both be automatically trying to renew via cron jobs or systemd timers.

Please show output of these two commands:

sudo crontab -l
systemctl list-timers | grep cert

#5

[root@mylinux ~]# sudo crontab -l
no crontab for root
[root@mylinux ~]# systemctl list-timers | grep cert
[root@mylinux ~]# sudo crontab -l
no crontab for root
[root@mylinux ~]#

I haven’t managed to create the certificate yet, which is my next issue.

#6

OK, that looks fine for now.
We’re here if you run into any walls - LOL

closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.