Problem to install certbot auto nginx: nginx plugin is not working

My domain is:trj.it

I ran this command:
sudo wget https://dl.eff.org/certbot-auto
sudo mv certbot-auto /jet/etc/letsencrypt/certbot-auto
sudo chown root /jet/etc/letsencrypt/certbot-auto
sudo chmod 0755 /jet/etc/letsencrypt/certbot-auto
sudo chmod a+x /jet/etc/letsencrypt/certbot-auto
sudo /jet/etc/letsencrypt/certbot-auto --nginx

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
The nginx plugin is not working; there may be problems with your existing configuration.
The error was: NoInstallationError(“Could not find a usable ‘nginx’ binary. Ensure nginx exists, the binary is executable, and your PATH is set correctly.”,)

My web server is (include version):

The operating system my web server runs on is (include version):
Linux lemp7-optimized-g2-1-vm 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64

My hosting provider, if applicable, is: google cloud compute engine

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):no, through ssh.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot-auto

log to /var/log/letsencrypt/letsencrypt.log :

2019-04-20 07:29:25,584:DEBUG:certbot.main:certbot version: 0.33.1
2019-04-20 07:29:25,584:DEBUG:certbot.main:Arguments: [’–nginx’]
2019-04-20 07:29:25,584:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#apache,PluginEntry$
2019-04-20 07:29:25,597:DEBUG:certbot.log:Root logging level set at 20
2019-04-20 07:29:25,598:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2019-04-20 07:29:25,599:DEBUG:certbot.plugins.selection:Requested authenticator nginx and installer nginx
2019-04-20 07:29:25,604:DEBUG:certbot.plugins.disco:No installation (PluginEntryPoint#nginx): Could not find a usa$
Traceback (most recent call last):
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/plugins/disco.py”, line 132, in prepare
self._initialized.prepare()
File “/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot_nginx/configurator.py”, line 143, in p$
"Could not find a usable ‘nginx’ binary. Ensure nginx exists, "
NoInstallationError: Could not find a usable ‘nginx’ binary. Ensure nginx exists, the binary is executable, and yo$
2019-04-20 07:29:25,605:DEBUG:certbot.plugins.selection:No candidate plugin
2019-04-20 07:29:25,605:DEBUG:certbot.plugins.selection:Selected authenticator None and installer None

A note: I have changed 10 hours ago the nameserver … it may be that I have to wait for the propagation before installing

Hi @RickyIta68

Certbot can’t find your nginx.

Do you use non-standard directories?

Check

there are two additional options:

  --nginx-server-root NGINX_SERVER_ROOT
                        Nginx server root directory. (default: /etc/nginx or
                        /usr/local/etc/nginx)
  --nginx-ctl NGINX_CTL
                        Path to the 'nginx' binary, used for 'configtest' and
                        retrieving nginx version number. (default: nginx)

Hi Juergen and thank you for reply and happy Easter

I also, before, tried to install certbot auto in other directories (/etc/letsencrypt/certbot auto )
but returned the same error …

ok, now I will try in this way :

sudo wget https://dl.eff.org/certbot-auto
sudo mv certbot-auto /jet/etc/letsencrypt/certbot-auto
sudo chown root /jet/etc/letsencrypt/certbot-auto
sudo chmod 0755 /jet/etc/letsencrypt/certbot-auto
sudo chmod a+x /jet/etc/letsencrypt/certbot-auto
sudo /jet/etc/letsencrypt/certbot-auto --nginx --nginx-ctl /usr/sbin/nginx --nginx-server-root /etc/nginx

1 Like

At the time I uninstalled certbot auto:

sudo unlink /jet/etc/letsencrypt/certbot-auto
sudo rm -r /opt/eff.org

I can’t get it to work unfortunately. It’s strange because in another vm instance identical to this one I performed the same procedure and I didn’t have any problems.

I don’t know how to solve

here there is a doc about the jetware vm istance:

http://jetware.io/appliances/jetware/lemp7_optimized_g2/profile

OK I have solved the problem … and I hope to have not problem with the renew of the certs

I have added a line to nginx.conf
user nobody nogroup; before launching the command:
sudo /jet/etc/letsencrypt/certbot-auto --nginx --nginx-ctl /jet/bin/nginx --nginx-server-root /jet/etc/nginx

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.