Failed install on CentOS 6.9 Nginx


#1

My operating system is:

CentOS 6.9

I installed Certbot with

: certbot-auto

I ran this command and it produced this output:

I ran

sudo ./path/to/certbot-auto --nginx

And it got most of the way through until it came here:

/opt/eff.org/certbot/venv/lib/python2.6/site-packages/cryptography/init.py:2 6: DeprecationWarning: Python 2.6 is no longer supported by the Python core team , please upgrade your Python. A future version of cryptography will drop support for Python 2.6
DeprecationWarning
Saving debug log to /var/log/letsencrypt/letsencrypt.log
The nginx plugin is not working; there may be problems with your existing config uration.
The error was: NoInstallationError()

I installed Python 3.5 and it produced the exact same output

Certbot's behavior differed from what I expected because:

I did not expect there to be an error from running the certbot-auto command

Here is a Certbot log showing the issue (if available):

Here is the log

#2

Certbot can’t find your nginx installation. How did you install nginx?


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.