Certbot : apache plugin not installed but I use httpd docker


#1

I’m a new for Certbot on server. Please advice.

I have tried to create new SSL for my website but I got this error on log

$ sudo certbot --apache -d MYDOMAIN

Saving debug log to /var/log/letsencrypt/letsencrypt.log
The requested apache plugin does not appear to be installed

Server

Ubuntu 16.04 : 64 bit
httpd 2.4 (docker container)

#2

Follow these instuctions:
https://certbot.eff.org/lets-encrypt/ubuntuxenial-apache.html


#3

In case you are blocked from reaching the certbot.EFF.org site, here are the instructions:

$ sudo apt-get update
$ sudo apt-get install software-properties-common
$ sudo add-apt-repository ppa:certbot/certbot
$ sudo apt-get update
$ sudo apt-get install python-certbot-apache

[EDIT] There are issues running cerbot inside docker.
You should also read this: https://certbot.eff.org/docs/install.html#running-with-docker


#4

Thanks for help.

I have tried and I stuck on this error.

I add test.txt file inside the .well-known/acme-challenge directory of my webroot. Then I tried to access via browser and it said, “You don’t have permission to access /.well-known/acme-challenge on this server.”

HTTP/1.1 403 Forbidden
Date: Thu, 24 May 2018 10:33:18 GMT
Server: Apache/2.4.33 (Unix) OpenSSL/1.0.2l
Content-Length: 220
Content-Type: text/html; charset=iso-8859-1

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /.well-known
on this server.<br />
</p>
</body></html>

Do you have any advice?

Here is permission of .well-know directory.

root@newProdDocker:~/docker/httpd/conf# ls -la /var/www/letsencrypt/
total 20
drwxrwxr-x 4 root root 4096 May 24 09:33 .
drwxrwxr-x 5 root root 4096 May 23 07:24 ..
-rwxrwxrwx 1 root root  127 May 22 03:51 index.html
drwxrwxr-x 3 root root 4096 May 24 04:38 .well-known

#5

Please show what’s inside it:
ls -l /var/www/letsencrypt/.well-known/
and what is in side the challenge folder:
ls -l /var/www/letsencrypt/.well-known/acme-challenge


#6

Inside

#  ls -l /var/www/letsencrypt/.well-known/
total 4
drwxrwxr-x 2 www-data www-data 4096 May 24 11:11 acme-challenge

Inside the /var/www/letsencrypt/.well-known/acme-challenge directory

ls -l /var/www/letsencrypt/.well-known/acme-challenge
total 4
-rwxrwxr-x 1 www-data www-data 9 May 24 04:38 test

#7

Maybe you have a rule in your web server configuration specifically denying access to paths that start with a . character?


#8

Thanks for your help. It’s work now.


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.