Certbot - apache plugin not installed


#1

Hi everyone !

My domain is: doesn’t really matter for my problem :°

I ran this command: certbot --apache

It produced this output:
“Saving debug log to /var/log/letsencrypt/letsencrypt.log
The requested apache plugin does not appear to be installed”

My operating system is (include version): Ubuntu 16.04 LTS

My web server is (include version): Apache2

My hosting provider, if applicable, is: Online.net (don’t really matter too)

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

Here is the letsencrypt.log file : https://pastebin.com/tgbqrg1G

I tried a lot of things and haven’t find anything on my search engine.
Please help :frowning:

Thanks


#2

Hi,

How did you install Certbot?


#3

I had a previous domain name that I don’t use anymore, and I needed to launch certbot to register a new cert for my domain. It’s been a long time that I installed it, but I already tried to apt-get remove it and reinstall it (I have it in my PPA), it did not change anything.

Thanks for the quick answer.

edit ; not sure if it’s really important, but I have two VirutalHosts on Apache.

edit 2 : I FOUND A SOLUTION o/
I just had to re-download the certbot-auto file from eff website and run it. It should have reinstalled the apache plugin, I don’t know.
Now it works normally.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.