Certbot missing Apache plugin


#1

My domain is: not relevant
I ran this command: certbot --apache
It produced this output: The requested apache plugin does not appear to be installed
My web server is (include version): Apache 2.4.18
The operating system my web server runs on is (include version): Ubuntu 16.04.4 LTS
My hosting provider, if applicable, is: self
I can login to a root shell on my machine (yes or no, or I don’t know): yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Upgraded from Letsencrypt 0.4.1 to certbot 0.22.2
Tried uninstalling/reinstalling certbot without any change.

So the question is:
How can I get the missing certbot Apache plugin installed?


#2

more /var/log/letsencrypt/letsencrypt.log
2018-04-04 10:48:27,872:DEBUG:certbot.main:certbot version: 0.22.2
2018-04-04 10:48:27,873:DEBUG:certbot.main:Arguments: [’–apache’]
2018-04-04 10:48:27,873:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2018-04-04 10:48:27,888:DEBUG:certbot.log:Root logging level set at 20
2018-04-04 10:48:27,889:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2018-04-04 10:48:27,890:DEBUG:certbot.plugins.selection:Requested authenticator apache and installer apache
2018-04-04 10:48:27,890:DEBUG:certbot.plugins.selection:No candidate plugin
2018-04-04 10:48:27,890:DEBUG:certbot.plugins.selection:Selected authenticator None and installer None

on other systems I see plugins for:
apache, manual, nginx, null, standalone, webroot


#3

Well it seems that the system did not have:
Package: python3-certbot-apache
“This package contains the Apache plugin to the main application.”

apt install python3-certbot-apache
seems to have done the trick.
not sure why it does not install automatically, nor did any plugins ask to be installed.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.