The requested apache plugin does not appear to be installed

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --apache

It produced this output: The requested apache plugin does not appear to be installed

My web server is (include version): apache2 (2.4.18-2ubuntu3.17)

The operating system my web server runs on is (include version): Ubuntu 16.04.7 LTS

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.27.0

Addendum: I ran 'sudo snap install --classic certbot' and got 'error: unable to contact snap store' Snap and snapd are installed.

I installed certbot using apt.

Hi @Wastrel, and welcome to the LE community forum :slight_smile:

That is an ancient version.
If that's all apt can find, then I would suggest that you should try using an alternate ACME client.


Thank you, Rudy. That's a start. has registered me but can't install the certificate because it doesn't have permission to write to /var/www/html. And it won't let me use sudo, but I will find a way to do it.

[Later] I created the directory it was looking for (/var/www/html/.well-known) and gave myself write permissions. Then I successfully obtained the certificate:

Wed Sep 28 15:49:56 CDT 2022] Your cert is in: /home/wastrel/
[Wed Sep 28 15:49:56 CDT 2022] Your cert key is in: /home/wastrel/
[Wed Sep 28 15:49:56 CDT 2022] The intermediate CA cert is in: /home/wastrel/
[Wed Sep 28 15:49:56 CDT 2022] And the full chain certs is there: /home/wastrel/

That all looked good. Then I ran:

./ --install-cert --domain

and there were no error messages.

Now I can go to and... I have an issue on the internal network with my firewall and its proxy connection to the web server, but I think I know what it is.

The instructions are never enough!

Thanks for your help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.