Certbor: Invalid Ip STATUS: [SOLVED]


#1

Hello fellas,

So today i was reciving this email from Lets Encrypt, that my certificates will run out. So i was checking my Cronjob that i configured, to automaticly renew the certificates.All Fine.

After that, i ran the command mannually and becate the following output:

Attempting to renew cert from /etc/letsencrypt/renewal/justingrah.me.conf produced an unexpected error: Failed authorization procedure. www.justingrah.me (tls-sni-01): urn:acme:error:unknownHost :: The server could not resolve a domain name :: No valid IP addresses found for www.justingrah.me. Skipping.

I’m running Apache 2.0 with PhP 7.0 on an Debain 8.0 Jessie.

I recently created an reverse DNS record for my mailserver. Can this be an problem?

Or did I messed up the DNS Configuration? (See Table below

  • TXT v=spf1 a aaaa mx ptr ~all
    @ AAAA 2a02:c207:3001:7082:0000:0000:0000:0001 //my IPV6
    @ A 173.212.207.128 //myIPV4
    @ TXT v=spf1 a aaaa mx ptr ~all
    autodiscover TXT 173.212.207.128
    backend A 173.212.207.128
    cloud A 173.212.207.128
    dav A 173.212.207.128
    default._domainkey TXT v=DKIM1;k=rsa;t=s;s=email;p=******
    mail A 173.212.207.128
    mail TXT v=spf1 a aaaa mx ptr ~all
    monitoring A 173.212.207.128
    _dmarc TXT v=DMARC1; p=quarantine; rua=mailto:******

Thanks for you help. Greetings from Germany!


#2

You have to set up a A/AAAA record for www


#3

Wow … Ok …didn’t thought about that :sweat_smile:

Thank you :+1:

#Solved


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.