Cannot renewing my certificate


#1

My domain is: nubes-leporum.ddns.net

I ran this command: sudo letsencrypt renew

It produced this output: …Attempting to renew cert (nubes-leporum.ddns.net) from /etc/letsencrypt/renewal/nubes-leporum.ddns.net.conf produced an unexpected error: Failed authorization procedure. nubes-leporum.ddns.net (tls-sni-01): urn:ietf:params:acme:error:unknownHost :: The server could not resolve a domain name :: No valid IP addresses found for nubes-leporum.ddns.net. Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/nubes-leporum.ddns.net/fullchain.pem (failure) …

My web server is (include version): apache2

The operating system my web server runs on is (include version): ubuntu 16.04 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

Be sure the IP resolves in global DNS and retry the request.
Also, you might want to adjust it to use, and allow for, http authentication:
--preferred-challenges http


#3

Hi @zefra

checked your domain via https://check-your-website.server-daten.de/?q=nubes-leporum.ddns.net

There is a Grade Y:

Y nubes-leporum.ddns.net
100.67.13.109
warning: Private ip address found

So it’s impossible to see / check your website worldwide. And http - 01 - validation isn’t possible.

But you can create a certificate using dns-01 - validation. Then no public ip address is required.


#4

Thank you for your help.
My Problem could be solved by changing the ip adrsss to a public.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.