Cannot renewing my certificate

Hi there,
my configuration worked properly for the last two years (totally unchanged) and since appr. five weeks I have this problem.
Thanks for all help

My domain is:

I ran this command: sudo certbot renew --dry-run

It produced this output: The following errors were reported by the server:

Type: connection
Detail: Fetching
Timeout during connect (likely firewall problem)
--> see also certbot error.txt as attachement

My web server is (include version): apache2

The operating system my web server runs on is (include version): ubuntu 16.04 LTS

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.31.0

certbot error.txt (31.7 KB)

From the error log:

"addressUsed": ""

From a current DNS lookup (Dig (DNS lookup)):

Was Let's Encrypt perhaps still using an old IP address which changed to the current one?

If so, please try again and check the logs that the validation server is actually using the correct IP address this time. Perhaps it took some time to propogate the last attempt.


You're right , is the current IP (I see also last DNS adjustment today at 4:45 CET). But notice, that the log is 3 days old. A current test (taken 5 minutes before) shows absolutly the same with the exeption of current IP adress.

Problem solved - the root cause concerns my provider.
Thanks for your time


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.