Cant get certbot working

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
mythmoor.com
I ran this command:
certbot certonly --standalone
It produced this output:
Problem binding to port 80
My web server is (include version):
IIS
The operating system my web server runs on is (include version):
Windows Server 2012r2
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
Certbot 1.7.0

I need to get this back up quickly I have been using letsencrypt for 4 years with no problem but seems this ACME change is now causing me to do things I should have never needed to do. I am willing to pay someone a small fee to help me please!

1 Like

Before it is asked yes I tried stopping IIS first, I also tried using certbot certonly --webroot while the server was running.

Then, is anything running on port 80 (while IIS is stopped) ?

1 Like

Not that I know of, IIS starts back up fine.

netstat shows inetinfo.exe but i try to stop that it just restarts

Have you always been using this certbot command? Because 4 years ago there was no certbot for Windows. So I’m enclined to think you’ve used an other ACME client before… Why the change to certbot?

1 Like

no im forced to make this change because I guess the acme 1 end of life things had worked fine for the last 4+ years and I don’t even remember how I set it up the first time, would be great if I could just pay someone 100 bucks to help me out here.

As of today my certificate is invalid now I am all kinds of messed up for what should be no reason.

The only things showing using http port is system

That is likely IIS.
Have you checked all your IIS site bindings?
Do you know how to turn IIS off (completely)?

Hi @maltechz

how? Don’t use the services, that’s wrong. Use the interface, there you have to stop the running website. That doesn’t stop the IIS, but stops port 80 listening.

1 Like