Cannot renew my SSL Certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: d.sh98.eu

I ran this command: sudo certbot renew (--dry-run)

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/d.sh98.eu.conf


Cert is due for renewal, auto-renewing...
Plugins selected: Authenticator apache, Installer apache
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for d.sh98.eu
Waiting for verification...
Cleaning up challenges
Attempting to renew cert (d.sh98.eu) from /etc/letsencrypt/renewal/d.sh98.eu.conf produced an unexpected error: HTTPSConnectionPool(host='acme-staging-v02.api.letsencrypt.org', port=443): Read timed out. (read timeout=45). Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/d.sh98.eu/fullchain.pem (failure)


** DRY RUN: simulating 'certbot renew' close to cert expiry
** (The test certificates below have not been saved.)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/d.sh98.eu/fullchain.pem (failure)
** DRY RUN: simulating 'certbot renew' close to cert expiry
** (The test certificates above have not been saved.)


1 renew failure(s), 0 parse failure(s)

My web server is (include version): apache 2.4.41

The operating system my web server runs on is (include version):Ubuntu Server 20.04

I can login to a root shell on my machine (yes or no, or I don't know):yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):v0.40.0

I don't know why it now fails, sometimes the dry run works but later the normal command fails.

2 Likes

Hi @sh98

see your check, created yesterday - https://check-your-website.server-daten.de/?q=d.sh98.eu

You have two different ipv4 addresses:

Host Type IP-Address is auth. ∑ Queries ∑ Timeout
d.sh98.eu A 87.122.206.19 Obertshausen/Hesse/Germany (DE) - VT-POOL1- dor002ibr101 No Hostname found yes 1 0
A 109.250.253.168 Offenbach/Hesse/Germany (DE) - 1&1 Versatel Deutschland GmbH Hostname: i6DFAFDA8.versanet.de yes 1 0
AAAA yes

The 87 works, the 109 has only timeouts. Looks like the 109 is expired / wrong.

3 Likes

Hi
Thx for your Help but how is it possible to have two ip addresses ?

2 Likes

That's always possible, a domain can have a lot of ip addresses, ipv4 and ipv6.

But every ip address must send the same answer. If the answers are different or if one ip address has a timeout -> that's fatal.

-->> Cleanup your dns entries.

3 Likes

Could you tell me how I can do it?

2 Likes

You have to change your dns entries - ns31.infomaniak.com is one of your name servers.

Check your domain management.

2 Likes

Ok alright I cleaned it up and now it works! Thank you a lot :slight_smile:

3 Likes

The error you received is likely not related to your nameservers. Here's an inquiry into the error:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.