Cannot access website after installing certbot correctly

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: apachectl -t -D DUMP_VHOSTS

It produced this output:VirtualHost configuration:
*:80 (/etc/apache2/sites-enabled/000-default.conf:1)
*:443 (/etc/apache2/sites-enabled/default-ssl.conf:2)

My web server is (include version):Apache2

The operating system my web server runs on is (include version):Debian 11

My hosting provider, if applicable, is:Contabo

I can login to a root shell on my machine (yes or no, or I don't know):yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):certbot 1.12.0

Website was working fine before I installed Certbot onto the server, After SSL cert was added it refuses to load html. I know port 80 and 443 are open and not blocked. The error in log files tell me i have an error on line 80 of Apache2.config

See the Console of your webbrowser: you have mixed content which prevents to load the JQuery file.


I am looking into that now but I still dont understand what causes that

So after changing out some files with another test website i have i got it to post something very very basic. still have an error in console

The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol.

See my previous reply:


well i appreciate the help, Im kinda new to using Apache or even building a website from scratch at all so i dont understand the mixed content ive tried googling it to understand but the only file i had in there was html.

The first hit on Google on "mixed content" results in my browser in:

This explains everything you need to know about mixed content. It indeed is a HTML issue.

Currently you serve an entirely different HTML file compared to earlier (and the green lock is visible now, which is to be expected), so diagnosing your previously issue is not possible.


Your page loads on https but your application is asking for resources on http. Tell whatever software is running your website (wordpress with a broken theme and no <html> element, I think) that its address starts with https. If you are using a reverse proxy, that gets more complicated but it's doable, tell us.

The encoding error is to be expected, you are missing the whole <head> section of the page.

1 Like

It seems to be posting the html, however no css or js

It's just part of the html. What did you remove to solve the first issue?


the whole orginal html file and replaced it with my test website

but if you look at it now it loads the html but nothing else i pulled this off google just to test and figure out

The issue is with how your wordpress is configured. There is nothing wrong with your webserver or certificate. Please put wordpress back :smiley:

1 Like

im not on wordpress. Im on a vps

if you are on discord i can screenshare and show you...

Please don't.

Is your html file the same your server is serving? (With no <head> etc etc?)

If yes, it's working as intended.


Im not having an issue with html im having an issue with css and js

I am telling you that your html page is not a complete html page (and it's not calling any js or css).


oh im dumb

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.