My website doesn´t display


#1

Hello,

I installed certbot, followed this: https://certbot.eff.org/lets-encrypt/ubuntuxenial-apache. Everything in the installation was succesful but my website doesn´t display with https.
I check my configuration at https://www.ssllabs.com/ssltest/analyze.html?d=nexusgaming.cz and it said “Warning: Inconsistent server configuration”

Does anyone have some ideas?

My domain is: nexusgaming.cz

I ran this command: sudo certbot --apache

My web server is (include version): apache2

The operating system my web server runs on is (include version): ubuntu 16.04, apache2

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

You have mixed content issues.

https://www.whynopadlock.com/results/86dfddab-c3fb-467e-9480-16249b7da235

Your AAAA record is also not a public IP, but that’s probably an unrelated issue.


#3

I tried to delete that script but unfortunately it´s not working now.


#4

Deleting it probably isn’t the right move, since your website depends on jQuery. After all, if your site didn’t depend on jQuery, then the mixed content issue wouldn’t be giving you grief to begin with.

You need to ensure you do not have any resources on your website that are loaded over insecure URLs (http://).

Any that you find need to be replaced with secure variants (https://).

The reason that your site is blank over HTTPS is because your body has a display: none; style set, presumably because of your WordPress theme or plugins that make it appear using jQuery. This issue is 100% related to your usage of WordPress, so you’ll need to work through each instance of mixed content and repair it in your theme.


#5

Thank you lot. After i replaced “http://” with “https://” it started display. :slight_smile:


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.