I have https but page not showing

Sorry for my english.

My domain is:
xdmister.eu
I ran this command:
certbot -appache
It produced this output:
Succesfuly you ahve certificate or something like this
My web server is (include version):
apache2
The operating system my web server runs on is (include version):
ubuntu
My hosting provider, if applicable, is:
my own
I can login to a root shell on my machine (yes or no, or I don't know):
yes
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.13.0

2 Likes

Hi @naxy73 Welcome to the forum!
So at first glance I notice that your port 443 is not accessible from the internet.

PORT    STATE    SERVICE
80/tcp  open     http
443/tcp filtered https

So check your firewall and make sure that 443 is open and available. That should get you going.

3 Likes

Also note that there is no redirect from HTTP to HTTPS. The command you ran should have tried to apply that redirect (if you choose to), but your Apache configuration might have prevented that. However, without the full output of your certbot command, we can't know what happened. You can check the log in /var/log/letsencrypt/.

And please don't generate any further certificates. You've managed to issue TEN certificates since March 7th! If you succesfully issued a certificate, but you don't have HTTPS, the problem is not with the issuing, but with something else. Therefore, re-issuing certificates is not helpful and is only contributing to the ever growing load on the Let's Encrypt systems. Please see the certbot documentation for all certbot options, such as certbot install.

3 Likes

sorry for your spended time thx.

1 Like

Something else that needs attention is your page is serving some insecure content.
Take a look at your html for any thing linking to http://

<link rel="stylesheet" href="http://xdmister.eu/assets/style/style.css">

Should be:

<link rel="stylesheet" href="https://xdmister.eu/assets/style/style.css">

Is one example.
Good luck.

4 Likes

Welcome to the Let's Encrypt Community :slightly_smiling_face:

The insecure content of which @Rip speaks is also known as "mixed content". You can use a tool like Missing Padlock to help identify other instances of "mixed content".

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.