AutoSSL encountered an Error

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: highlinedevworks.com

I ran this command: Run AutoSSL

It produced this output:
DNS DCV: The DNS query to “_cpanel-dcv-test-record.highlinedevworks.com” for the DCV challenge returned no “TXT” record that matches the value “_cpanel-dcv-test-record=6DSUmpgDo_WxRKgGyOCqwKEvm1szlBXdlBLUkxquIOUJAOrnBGwLSIkjXq2fhJYu”.; HTTP DCV: “cPanel (powered by Sectigo)” forbids DCV HTTP redirections.

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Cloudflare

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel 86.0.18

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Ask your host, you aren’t using Let’s Encrypt so it’s not really a question for this forum.

Some hints:

cPanel DNS DCV fails because you’re hosting your DNS with Cloudflare, so cPanel doesn’t have access to create TXT records for your domain. That’s fine, it can fall back to HTTP DCV.

You probably need to remove the “Always use HTTPS” redirection in your Cloudflare security settings for this to work.

Though, if that doesn’t work, the explanation might be that cPanel AutoSSL simply doesn’t support domains which are being proxied by Cloudflare: https://forums.cpanel.net/threads/autossl-forbids-dcv-http-redirection-subdomain.629751/post-2561799

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.