Assistance with Installing CertBot: python-certbot-nginx

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: apt-get install certbot python-certbot-nginx -t stretch-backports

It produced this output: E: Unable to locate package python-certbot-nginx

My web server is (include version): NGINX v1.10.3

The operating system my web server runs on is (include version): Debian 9.9

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): N/A, can’t get it installed because package is not found.

Hello All,

I am trying to install CertBot on my Debian 9 instance with NGINX. I have added the proper backports repository as instructed by the documentation, but the problem is that the following command returns an error with the package: apt-get install certbot python-certbot-nginx -t stretch-backports

It cannot find ptython-certbot-nginx.

Any recommendations?

Thanks!

Z

That package is just a legacy package for the transition from Python 2 to Python 3.

You might want to try python3-certbot-nginx

How did you add the stretch-backports repository to your list of repos? Did you run ‘apt-get update’ after to bring in the repo metadata?

Hi Osiris,

I am receiving the same error when trying to run that command as well.

Thanks!

Z

Hi mproto,

I added the stretch-backports utilizing the following documentation:

Listed on the CertBot website installation instructions: https://backports.debian.org/Instructions/

That link did not work for me, so I utilized the following Debian Wiki to install the backports: https://wiki.debian.org/Backports

Specifically, the ‘Using the Command Line’ section of this documentation. I did run apt-get update and it is hitting the repo successfully.

Any other thoughts?

Thanks!

Z

Hmm I just installed Debian 9.9 in a VM and after adding static-backports I could find both packages immediately.

What results do you get with ‘apt-cache search certbot’ ?

Hi mrproto,

Thank you for the update… this is very interesting. Running that command I can see both of the packages sitting there. I wonder why when I try to install them it declares it couldn’t find those packages.

Maybe it’s an issue with how I added the repo. I’m going to have to do some digging on this one.

Thanks!

Z

Sure! When you find your answer kindly report back here, in case someone runs into a similar problem as yours in the future.

1 Like

Hi mproto,

I certainly will!

Hope to update soon!

Thanks for your assistance!

Z

Hi All,

I was able to resolve this issue, I don’t necessarily think it was an issue with how I installed the backports, but rather the format of the command given on the website for installing python-certbot-nginx.

Here is the command:

$ sudo apt-get install certbot python-certbot-nginx -t stretch-backports

Listed on the certbot website, located here: https://certbot.eff.org/lets-encrypt/debianstretch-nginx

I utilized the following backport sources:

deb http://deb.debian.org/debian stretch-backports main

deb-src http://deb.debian.org/debian stretch-backports main

I was able to hit the backports successfully when I would run apt-get update.

I was then able to install python-certbot-nginx by utilizing the following command:

apt-get -t stretch-backports install python-certbot-nginx

It is now successfully installed. If i try running the command from the website however, I still have the same error.

I am not that well versed in Linux, so maybe there is something I am missing. But it appears this was a formatting issue with the installation command. Someone can correct this if that is incorrect.

Thanks!

Z

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.