Installing Certbot fails on Debian 9 using apt-get

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
www.davidsfolly.com/

I ran this command:
sudo apt-get update

then:

sudo apt-get install python-certbot-apache -t stretch-backports

It produced this output:

Reading package lists… Done
E: The value ‘stretch-backports’ is invalid for APT::Default-Release as such a release is not available in the sources

My web server is (include version):

Server version: Apache/2.4.25 (Debian)
Server built: 2017-09-19T18:58:57

The operating system my web server runs on is (include version):

Distributor ID: Debian
Description: Debian GNU/Linux 9.3 (stretch)
Release: 9.3
Codename: stretch

My hosting provider, if applicable, is:

Linode

I can login to a root shell on my machine (yes or no, or I don’t know):

Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

No

First time user here. Assistance appreciated. Thanks.

Did you follow the instructions to add the stretch backports, as instructed on the certbot manual on Debian 9 for Apache?

Thank you Osiris! That solved the problem for me!!!

I’m not sure how my eyes glossed over that line. The light-blue link didn’t help any. :blush:

1 Like

What what things happen if I simply drop the -t stretch-backports?

The debian instructions would not apply to me, since I’m actually using stretch via Raspbian (on a Raspberry Pi 3), and Raspbian does not have backports per https://www.raspberrypi.org/forums/viewtopic.php?t=190124

It probably wouldn't find the package you need.

I had to read it twice too :wink:

1 Like

I went with the “other unix” option.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.