Apache - SSL Configuration File Stability


#1

All my ssl-conf files got automatically disabled and hence, received this error: SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long). Turns out that the conf files had to be re-enabled to get the site running. Any idea why this might have happened?

Please fill out the fields below so we can help you better.

My domain is: oldhonk.co.in

I ran this command: oldhonk.co.in on web browser

It produced this output: SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

My operating system is (include version): Ubuntu 16.04

My web server is (include version): Apache

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no


#2

Nope.

But I have to ask: how is this exactly related to Let’s Encrypt? Did you install a Let’s Encrypt certificate? Did you do something with your client recently which could have caused this issue? Which client was that and what did you do? Et cetera, et cetera…


#3

can you clarify what you mean by this.

Andrei


#4

Probably the symlinks in sites-enabled to configuration files within sites-available.


#5

Yes, I have installed Let’s Encrypt certificate which led to the creation of www.oldhonk.co.in-le-ssl.conf from the already existing VH (Virtual Host) file as www.oldhonk.co.in.conf.
And no, no changes were done with the conf files and hence the question. How come all my ssl-conf files got disabled. And as @schoen correctly mentioned, those conf files were not present in my sites-enabled .


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.