Apache not found

My domain is: theapothecary.app

I ran this command: sudo certbot --apache

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
The apache plugin is not working; there may be problems with your existing configuration.
The error was: NoInstallationError('Cannot find Apache executable apache2ctl')
root@loyali:/home/ubuntu# sudo certbot certonly --apache
Saving debug log to /var/log/letsencrypt/letsencrypt.log

My web server is (include version): Apache (installed with Wordpress: latest over docker) do I have to install a stand alone Apache?

The operating system my web server runs on is (include version): Ubuntu 22 Arm64

My hosting provider, if applicable, is: Registrar Google -- Hosted on Oracle

I can login to a root shell on my machine (yes or no, or I don't know): YES

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

I am following the steps given on this page: Certbot Instructions | Certbot

Thanks for the help!!

The problem is likely that certbot can't "see" your apache instance in Docker.


When I enter your domain theapothecary.app with http://theapothecary.app and https://theapothecary.app it shows nothing.


Look at this LE community topic for domain name issue solution ideas: HTTP-01 validation fails: no valid A/AAAA records found for domain


Also, here DNS Lookup - Check DNS Records (dnschecker.org) does not show and DNS records for type A, AAAA, nor CNAME.


@Deborah I see you continue to struggle with fundamental issues. There are hosting services that offer quick setup of blogs, websites and similar. It is not necessary to put together all the pieces yourself. You could use such a hosting service to start and as you learn more you could try the do-it-yourself approach later. Just an idea.

If you want to continue this DIY path the Let's Debug test site will be helpful while you get the initial setup sorted out


And to add to @griffin s post: when using Certbot and/or your webserver in Docker, you should use the webroot plugin as authenticator plugin, manually install the certificate into your webserver and make sure your webserver is reloaded somehow after renewal. (Not sure if a --deploy-hook from within Docker container A can reload a webserver in Docker container B tho..)


thanks for checking, Google doesn't host it anymore, it's on Oracle now. I think neither cloudflare nor oracle resolved this simple thing of propagating a DNS.


Yes Mike, seems all bloggers and YouTubers lack fundaments, I am more inclined to hiring a professional on a freelance platform because hosts have given me some pain using mautic. I decided not to be trying everyone of them but really, the only community that helps is LE and the horde of Bloggers and Youtubers out there seem to lack fundamentals. Thanks for taking the time.


Probably it hasn't propagated yet.
Last time I quit Cloudflare and moved to oracle was:Wed, Jun 29, 2022, 21:40:15 UTC

1 Like

This may help:




Here is the .yml example for docker, can be managed on portainer:

version: '2'
    image: oznu/cloudflare-ddns:latest
    restart: always
      - API_KEY=xxxxxxx
      - ZONE=example.com
      - SUBDOMAIN=subdomain
      - PROXIED=false

it worked well with Nginx-cloudflare on docker, but I got error 504 and cloudflare is an ocean of info with no support for free tier...


will give it another try... after this weekend I will just pay a tribute to pros... hahaha you deserve it!

1 Like

oh yeah I saw this page yesterday, there's no plugin for oracle, OCI, oraclecloud or anything Oracle related... will move back to google for good...

1 Like

There is an A record for your blog subdomain but there is no A record for your apex name theapothecary.app. You will need one to get a cert for that name using an HTTP challenge.


Certbot and Docker are no natural friends:
" Docker is an amazingly simple and quick way to obtain a certificate. However, this mode of operation is unable to install certificates or configure your webserver, because our installer plugins cannot reach your webserver from inside the Docker container."

1 Like

Thanks I have created that A for the domain.

By this time:

Serial: 304097123638573985608224842593589061917427
NotBefore: 2022-06-29 14:31:13 +0000 UTC
Names: [blog.theapothecary.app]

It was still on cloudflare and I got a certificate using Nginx for blog.domain. Only all the set up resulted in error 504...



1 Like

This sample URL for an HTTP challenge should result in a 404 Not Found as the file Forum123 does not exist. But, you redirect it to a WP install page instead. For an actual challenge you need to reply with the challenge file data.

And, you'll also need to deal with the docker coordination which I am not expert at so cannot help with that.

curl -I theapothecary.app/.well-known/acme-challenge/Forum123

HTTP/1.1 302 Found
Date: Fri, 01 Jul 2022 14:30:42 GMT
Server: Apache/2.4.53 (Debian)
X-Powered-By: PHP/7.4.30
X-Redirect-By: WordPress
Location: http://theapothecary.app/wp-admin/install.php
(other headers omitted for clarity)

Well when I ping theapothecary.app
PING theapothecary.app (****): 56 data bytes
there is an IPv4 Address, so that is a good thing.