Apache error Digital Ocean Ubuntu 18

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --apache

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
The apache plugin is not working; there may be problems with your exiting configuration.
The error was: NoInstallationError('Cannot find Apache executable apahe2ctl')

My web server is (include version): ???

The operating system my web server runs on is (include version): Ubuntu 18.04 (LTS) x64

My hosting provider, if applicable, is: Digital Ocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Certbot 1.18.0

I am very new to Ubuntu and would like to learn it from the mistakes and errors that I encounter. Any and all help is appreciated.

Hi @edrivas411, welcome to the LE community forum :slight_smile:

How was Apache installed?
Have you tried using the --webroot method?

I am new and just follow the commands Ubuntu tells me when I do something wrong or what a website tells me. I do not recall ever installing apache.

Do you have a website there?
If so, which web server are you using for that?

I have a unifi controller on there. Today I got my message to renew my cert.

Please show the message.
And the output of:
certbot certificates

And when did you install certbot?

Your certificate (or certificates) for the names listed below will expire in 10 days (on 09 Sep 21 02:28 +0000). Please make sure to renew your certificate before then, or visitors to your web site will encounter errors.

output of certbot certificates

no certificates found.

I am just realizing that it was for a previous controller I used under same website.

I am so glad you responded or I would have been searching to fix this for days

The more information you hold back the less we can help you (with).

I was not holding back I just removed the greeting and closing.


Your certificate (or certificates) for the names listed below will expire in 10 days (on 09 Sep 21 02:28 +0000). Please make sure to renew your certificate before then, or visitors to your web site will encounter errors.

We recommend renewing certificates automatically when they have a third of their total lifetime left. For Let's Encrypt's current 90-day certificates, that means renewing 30 days before expiration. See Integration Guide - Let's Encrypt for details.


For any questions or support, please visit: https://community.letsencrypt.org/ Unfortunately, we can't provide support by email.

For details about when we send these emails, please visit: Expiration Emails - Let's Encrypt In particular, note that this reminder email is still sent if you've obtained a slightly different certificate by adding or removing names. If you've replaced this certificate with a newer one that covers more or fewer names than the list above, you may be able to ignore this message.

If you are receiving this email in error, unsubscribe at:
Please note that this would also unsubscribe you from other Let's Encrypt service notices, including expiration reminders for any other certificates.

The Let's Encrypt Team

This is generally not considered a domain:

This, however, is always considered a domain:

And we can start helping you now, with that information.

Oh I am sorry I thought the domain was the main site and not the site within the site as I see it. I am really new to this so I am sorry I was not as clear as I should have been.

1 Like

The name seems to have been renewing for many months now without issue.
Has anything changed in the past few months?

Yes the controller went down so bad I just had to scrap the droplet and rebuild it. The new method I used to rebuild it did not have lets encrypt on it. I now need to figure out how to add it. Previously I used crosstalk solutions 15 minute guide and this time I used a unifi guide to build it

Well therein lies the problem.

Did that guide cover TLS/SSL/HTTPS/Encryption ?

No it does not. So I need to figure out how to do it. There is an issue with Ubuntu 18 and Unifi controller so it was a completely new process and I need to figure out how that process built it and then get a cert for that controller.

This page might be helpful to you:

Which for the hard-of-reading can be summarized in this key portion:

Thank You

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.